Etc portage package unmask needs updating

14-Oct-2019 05:58 by 7 Comments

Etc portage package unmask needs updating - david tennat dating

CFLAGS="-march=native -mtune=generic -O2 -pipe"CXXFLAGS="$"# WARNING: Changing your CHOST is not something that should be done lightly.# Please consult changing.

Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf!!! * Main active version of Python: 3.3 * Active version of Python 2: 2.7 * Active version of Python 3: 3.3 * Globally supported Python ABIs in installed repositories: * gentoo: 2.4 2.5 2.6 2.7 3.1 3.2 3.3 2.5-jython 2.7-jython 2.7-pypy-1.7 2.7-pypy-1.8 2.7-pypy-1.9 2.7-pypy-2.0!!! * Use eselect news read to view new items.#eselect postgresql list Available Postgre SQL Slots 9.2 * server-9.2.7 base-9.2.7 9.3 base-9.3.3#eix -s postgresql[I] app-eselect/eselect-postgresql Available versions: 1.2.1 Installed versions: 1.2.1( ) Homepage: Description: Utility to select the default Postgre SQL slot[U] dev-db/postgresql Available versions: (9.0) 9.0.19^t ~9.0.19-r1^t (9.1) 9.1.15^t ~9.1.15-r1^t (9.2) 9.2.10 ~9.2.10-r1 (9.3) 9.3.6 ~9.3.6-r1 (9.4) 9.4.1 ~9.4.1-r1 (9.5) **9999 Installed versions: 9.2.7(9.2)^t( )(kerberos nls pam python readline ssl zlib -doc -ldap -pg_legacytimestamp -threads LINGUAS="ru -af -cs -de -en -es -fa -fr -hr -hu -it -ko -nb -pl -pt_BR -ro -sk -sl -sv -tr -zh_CN -zh_TW" PYTHON_SINGLE_TARGET="python2_7 -python2_6 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python2_6 -python3_2") 9.3.3(9.3)^t( )(kerberos nls pam python readline ssl zlib -doc -ldap -pg_legacytimestamp -threads LINGUAS="ru -af -cs -de -en -es -fa -fr -hr -hu -it -ko -nb -pl -pt_BR -ro -sk -sl -sv -tr -zh_CN -zh_TW" PYTHON_SINGLE_TARGET="python2_7 -python2_6 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python2_6 -python3_2") Homepage: Description: Postgre SQL RDBMS# emerge -av dev-lang/perl * IMPORTANT: config file '/etc/portage/package.accept_keywords' needs updating.Whenever you install software on your system with the emerge command, the Portage tree is searched.If a matching package name is found, its dependencies are calculated, the source code for the package and its dependencies are downloaded and then they're all compiled and installed onto your system.into the dependency graph, resulting in a slot conflict: dev-libs/openssl:0 (dev-libs/openssl-1.0.1g::gentoo, ebuild scheduled for merge) pulled in by =dev-libs/openssl-1.0.0:0[-bindist] required by (net-dns/bind-9.9.4_p2::gentoo, ebuild scheduled for merge) dev-libs/openssl:0[-bindist] required by (net-dns/bind-9.9.4_p2::gentoo, ebuild scheduled for merge) (dev-libs/openssl-1.0.1g::gentoo, installed) pulled in by =dev-libs/openssl-0.9.6d:0[bindist] required by (net-misc/openssh-5.9_p1-r4::gentoo, installed) It may be possible to solve this problem by using to prevent one of those packages from being selected.However, it is also possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously. Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/* IMPORTANT: 9 news items need reading for repository 'gentoo'. These are the packages that would be merged, in order: Calculating dependencies... [ebuild U ] sys-libs/libcap-ng-0.7.4::gentoo [0.7.3::gentoo] USE="python -static-libs" PYTHON_TARGETS="python2_7%* python3_3%* -python3_4%" 398 Ki BTotal: 1 package (1 upgrade), Size of downloads: 398 Ki B!!!

Multiple package instances within a single package slot have been pulled !!!

If such a conflict exists in the dependencies of two different packages, then those packages can not be installed simultaneously.

You may want to try a larger value of the --backtrack option, such as --backtrack=30, in order to see if that will solve this conflict automatically.

To get into a Root Shell either use the su (switch user) command by typing su - (the "-" means change to that user's settings and home directory) or press Alt-F2 and type kdesu shellprogram or gnomesu shellprogram where shellprogram is "konsole", "gnome-terminal", "xterm" (without the quotes) or another. The most useful toolbar known to new Sabayon users is the Run Command Dialog, which allows you to run all sorts of programs and commands simply by typing the name of the command and pressing Enter. GENERALLY YOU WILL WANT TO IGNORE THE FIRST METHOD BELOW!!! For specific examples or command line examples with all the correct options for each step use Google :), or your brain.

To get to a Shell, press Alt-F2 (the shortcut key for the Run command window) and type konsole or gnome-terminal or xterm depending on your preference. Because it is an easy way for issuing multiple commands on one line. Longer answer: This depends on what method you are using or what software you want to install.

into the dependency graph, resulting in a slot conflict: dev-lang/perl:0 (dev-lang/perl-5.20.2:0/5.20::gentoo, ebuild scheduled for merge) pulled in by dev-lang/perl (Argument) =dev-lang/perl-5.20* required by (virtual/perl-Digest-1.170.0-r4:0/0::gentoo, installed) ^ ^^^^^ (and 1 more with the same problems) (dev-lang/perl-5.16.3:0/5.16::gentoo, installed) pulled in by dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Pl RPC-0.202.0-r2:0/0::gentoo, installed) ^^^^^^^^ (and 22 more with the same problem)It may be possible to solve this problem by using toprevent one of those packages from being selected.